package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$`)
var str = `rabbithole-007
r340j-
8jh
jo9
d366gg-
synthetic-cargo-343207
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-
d4jikkj34jk34j34jk3jk4j
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd
rabbit-hole-integration-007`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}