import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$";
final String string = "rabbithole-007\n"
+ "r340j-\n"
+ "8jh\n"
+ "jo9\n"
+ "d366gg-\n"
+ "synthetic-cargo-343207\n"
+ "d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-\n"
+ "d4jikkj34jk34j34jk3jk4j\n"
+ "d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd\n"
+ "rabbit-hole-integration-007";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}