#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Vorgänger.*(\d+)$"
Local $sString = "Vorgänger Material Level __3" & @CRLF & _
"Vorgänger Material Level 4" & @CRLF & _
"Vorgänger Material Level _2" & @CRLF & _
"Vorgänger Material Level _2" & @CRLF & _
"" & @CRLF & _
"Nachfolge Material Level 1" & @CRLF & _
"Nachfolge Material Level _2" & @CRLF & _
"Nachfolge Material Level _2" & @CRLF & _
"Nachfolge Material Level 1" & @CRLF & _
"Nachfolge Material Level _2" & @CRLF & _
"Nachfolge Material Level _2" & @CRLF & _
"" & @CRLF & _
"Nachfolge Material Level 1" & @CRLF & _
"Nachfolge Material Level _2" & @CRLF & _
"Nachfolge Material Level 1" & @CRLF & _
"Vorgänger Material Level 1" & @CRLF & _
"Vorgänger Material Level 1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")