// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Vorgänger.*(\d+)$").unwrap();
let string = "Vorgänger Material Level __3
Vorgänger Material Level 4
Vorgänger Material Level _2
Vorgänger Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level 1
Vorgänger Material Level 1
Vorgänger Material Level 1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}