using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Vorgänger.*(\d+)$";
string input = @"Vorgänger Material Level __3
Vorgänger Material Level 4
Vorgänger Material Level _2
Vorgänger Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level 1
Vorgänger Material Level 1
Vorgänger Material Level 1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}