re = /^Vorgänger.*(\d+)$/m
str = 'Vorgänger Material Level __3
Vorgänger Material Level 4
Vorgänger Material Level _2
Vorgänger Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level 1
Vorgänger Material Level 1
Vorgänger Material Level 1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end