$re = '/^Vorgänger.*(\d+)$/m';
$str = 'Vorgänger Material Level __3
Vorgänger Material Level 4
Vorgänger Material Level _2
Vorgänger Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level 1
Vorgänger Material Level 1
Vorgänger Material Level 1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);