package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Vorgänger.*(\d+)$`)
var str = `Vorgänger Material Level __3
Vorgänger Material Level 4
Vorgänger Material Level _2
Vorgänger Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level _2
Nachfolge Material Level 1
Nachfolge Material Level _2
Nachfolge Material Level 1
Vorgänger Material Level 1
Vorgänger Material Level 1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}