import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Vorgänger.*(\\d+)$";
final String string = "Vorgänger Material Level __3\n"
+ "Vorgänger Material Level 4\n"
+ "Vorgänger Material Level _2\n"
+ "Vorgänger Material Level _2\n\n"
+ "Nachfolge Material Level 1\n"
+ "Nachfolge Material Level _2\n"
+ "Nachfolge Material Level _2\n"
+ "Nachfolge Material Level 1\n"
+ "Nachfolge Material Level _2\n"
+ "Nachfolge Material Level _2\n\n"
+ "Nachfolge Material Level 1\n"
+ "Nachfolge Material Level _2\n"
+ "Nachfolge Material Level 1\n"
+ "Vorgänger Material Level 1\n"
+ "Vorgänger Material Level 1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}