# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\h++)|\h*+(?<=[\h,]|^)(?!$|,)((?:[^",\n]|\\.)*?|"(?:[^\\\n"]*+|"[^\\\n"]*"|\\.)*"|[^"\n]+"[^"\n]*)(?=\h*,|$)|"(?:[^",\n]|\\.)*,.*+$/$2/gm;t' <<< "for this. , OK \\"it\\" is,\"hmmm\", \"item \"three\"\", a, yup
one, tw\"o, three\", \"four, five\", \"six\", \"s\"e,\"v,\"e,\"n\", \\"eight, \"nine, \"ten\", eleven"