import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\h++)|\\h*+(?<=[\\h,]|^)(?!$|,)((?:[^\",\\n]|\\\\.)*?|\"(?:[^\\\\\\n\"]*+|\"[^\\\\\\n\"]*\"|\\\\.)*\"|[^\"\\n]+\"[^\"\\n]*)(?=\\h*,|$)|\"(?:[^\",\\n]|\\\\.)*,.*+$";
final String string = "for this. , OK \\\"it\\\" is,\"hmmm\", \"item \"three\"\", a, yup\n\n"
+ "one, tw\"o, three\", \"four, five\", \"six\", \"s\"e,\"v,\"e,\"n\", \\\"eight, \"nine, \"ten\", eleven";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}