# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\h++)|\h*+(?<=[\h,]|^)(?!$|,)((?:[^\",\n]|\\.)*?|\"(?:[^\\\n\"]*+|\"[^\\\n\"]*\"|\\.)*\"|[^\"\n]+\"[^\"\n]*)(?=\h*,|$)|\"(?:[^\",\n]|\\.)*,.*+$"
test_str = ("for this. , OK \\\"it\\\" is,\"hmmm\", \"item \"three\"\", a, yup\n\n"
"one, tw\"o, three\", \"four, five\", \"six\", \"s\"e,\"v,\"e,\"n\", \\\"eight, \"nine, \"ten\", eleven")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.