const regex = /(\h++)|\h*+(?<=[\h,]|^)(?!$|,)((?:[^",\n]|\\.)*?|"(?:[^\\\n"]*+|"[^\\\n"]*"|\\.)*"|[^"\n]+"[^"\n]*)(?=\h*,|$)|"(?:[^",\n]|\\.)*,.*+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\h++)|\\h*+(?<=[\\h,]|^)(?!$|,)((?:[^",\\n]|\\\\.)*?|"(?:[^\\\\\\n"]*+|"[^\\\\\\n"]*"|\\\\.)*"|[^"\\n]+"[^"\\n]*)(?=\\h*,|$)|"(?:[^",\\n]|\\\\.)*,.*+$', 'gm')
const str = `for this. , OK \\"it\\" is,"hmmm", "item "three"", a, yup
one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \\"eight, "nine, "ten", eleven`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);