$re = '/(\h++)|\h*+(?<=[\h,]|^)(?!$|,)((?:[^",\n]|\\\\.)*?|"(?:[^\\\\\n"]*+|"[^\\\\\n"]*"|\\\\.)*"|[^"\n]+"[^"\n]*)(?=\h*,|$)|"(?:[^",\n]|\\\\.)*,.*+$/m';
$str = 'for this. , OK \\"it\\" is,"hmmm", "item "three"", a, yup
one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \\"eight, "nine, "ten", eleven';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;