using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\h++)|\h*+(?<=[\h,]|^)(?!$|,)((?:[^"",\n]|\\.)*?|""(?:[^\\\n""]*+|""[^\\\n""]*""|\\.)*""|[^""\n]+""[^""\n]*)(?=\h*,|$)|""(?:[^"",\n]|\\.)*,.*+$";
string substitution = @"$2";
string input = @"for this. , OK \""it\"" is,""hmmm"", ""item ""three"", a, yup
one, tw""o, three"", ""four, five"", ""six"", ""s""e,""v,""e,""n"", \""eight, ""nine, ""ten"", eleven";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}