import Foundation
let pattern = #"(\h++)|\h*+(?<=[\h,]|^)(?!$|,)((?:[^",\n]|\\.)*?|"(?:[^\\\n"]*+|"[^\\\n"]*"|\\.)*"|[^"\n]+"[^"\n]*)(?=\h*,|$)|"(?:[^",\n]|\\.)*,.*+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
for this. , OK \"it\" is,"hmmm", "item "three"", a, yup
one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \"eight, "nine, "ten", eleven
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)