#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))"
Local $sString = "39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39" & @CRLF & _
"39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39" & @CRLF & _
"&&&39 ;;39 &; 39;" & @CRLF & _
"padding: 39%;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")