const regex = /(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))', 'gm')
const str = `39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39
39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39
&&&39 ;;39 &; 39;
padding: 39%;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}