import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))";
final String string = "39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39\n"
+ "39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39\n"
+ "&&&39 ;;39 &; 39;\n"
+ "padding: 39%;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}