re = /(?:^&[^&;]*?)?(39)(?!(?:[^&;]*?;))|(?:(?:^|;)(?:[^&;]*?)(39))/m
str = '39;&39<img border=39'0'&39; &39 &39; 39test; 39; />39
39; 39%; some text in between without searched text; 39 test &; test39 39 23 39; test test 39
&&&39 ;;39 &; 39;
padding: 39%;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end