#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9!#$^&*|\-_+=~`?"]*([A-Za-z0-9!#$^&*|\-_+=~`?"]\.[A-Za-z0-9!#$^&*|\-_+=~`?"]+)*(\.{0,1}[A-Za-z0-9!#$^&*|\-_+=~`?"]@[A-Za-z0-9!#$^&*|\-_+=]{1,60})(\.[A-Za-z0-9!#$^&*|\-_+=~`?"]{2,60})*$"
Local $sString = "this.is.an.email@email.com" & @CRLF & _
"whatsinthebox@se7en" & @CRLF & _
"mpAdm1n@localhost" & @CRLF & _
"tyler.knappenberger@Gnostech.com" & @CRLF & _
"Damned.Proud.To.Be.Here@Gnostech.com" & @CRLF & _
"George.Washington@potus.gov" & @CRLF & _
"0123456789@numbers.num" & @CRLF & _
"~!#$^&*_-+|=?"@special.chars" & @CRLF & _
"tknappenberger@student.lasalle.edu" & @CRLF & _
"jane.doe45@navy.gov" & @CRLF & _
"2.e@s" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Not an Email@whitespace.org" & @CRLF & _
"this%doesntWork@percentsDont.work" & @CRLF & _
"duplicate..periods@localhost" & @CRLF & _
".emalt@w"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")