$re = '/^[A-Za-z0-9!#$^&*|\-_+=~`?"]*([A-Za-z0-9!#$^&*|\-_+=~`?"]\.[A-Za-z0-9!#$^&*|\-_+=~`?"]+)*(\.{0,1}[A-Za-z0-9!#$^&*|\-_+=~`?"]@[A-Za-z0-9!#$^&*|\-_+=]{1,60})(\.[A-Za-z0-9!#$^&*|\-_+=~`?"]{2,60})*$/m';
$str = 'this.is.an.email@email.com
whatsinthebox@se7en
mpAdm1n@localhost
tyler.knappenberger@Gnostech.com
Damned.Proud.To.Be.Here@Gnostech.com
George.Washington@potus.gov
0123456789@numbers.num
~!#$^&*_-+|=?"@special.chars
tknappenberger@student.lasalle.edu
jane.doe45@navy.gov
2.e@s
Not an Email@whitespace.org
this%doesntWork@percentsDont.work
duplicate..periods@localhost
.emalt@w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);