import Foundation
let pattern = ##"^[A-Za-z0-9!#$^&*|\-_+=~`?"]*([A-Za-z0-9!#$^&*|\-_+=~`?"]\.[A-Za-z0-9!#$^&*|\-_+=~`?"]+)*(\.{0,1}[A-Za-z0-9!#$^&*|\-_+=~`?"]@[A-Za-z0-9!#$^&*|\-_+=]{1,60})(\.[A-Za-z0-9!#$^&*|\-_+=~`?"]{2,60})*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
this.is.an.email@email.com
whatsinthebox@se7en
mpAdm1n@localhost
tyler.knappenberger@Gnostech.com
Damned.Proud.To.Be.Here@Gnostech.com
George.Washington@potus.gov
0123456789@numbers.num
~!#$^&*_-+|=?"@special.chars
tknappenberger@student.lasalle.edu
jane.doe45@navy.gov
2.e@s
Not an Email@whitespace.org
this%doesntWork@percentsDont.work
duplicate..periods@localhost
.emalt@w
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)