import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9!#$^&*|\\-_+=~`?\"]*([A-Za-z0-9!#$^&*|\\-_+=~`?\"]\\.[A-Za-z0-9!#$^&*|\\-_+=~`?\"]+)*(\\.{0,1}[A-Za-z0-9!#$^&*|\\-_+=~`?\"]@[A-Za-z0-9!#$^&*|\\-_+=]{1,60})(\\.[A-Za-z0-9!#$^&*|\\-_+=~`?\"]{2,60})*$";
final String string = "this.is.an.email@email.com\n"
+ "whatsinthebox@se7en\n"
+ "mpAdm1n@localhost\n"
+ "tyler.knappenberger@Gnostech.com\n"
+ "Damned.Proud.To.Be.Here@Gnostech.com\n"
+ "George.Washington@potus.gov\n"
+ "0123456789@numbers.num\n"
+ "~!#$^&*_-+|=?\"@special.chars\n"
+ "tknappenberger@student.lasalle.edu\n"
+ "jane.doe45@navy.gov\n"
+ "2.e@s\n\n\n"
+ "Not an Email@whitespace.org\n"
+ "this%doesntWork@percentsDont.work\n"
+ "duplicate..periods@localhost\n"
+ ".emalt@w";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}