// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^[A-Za-z0-9!#$^&*|\-_+=~`?"]*([A-Za-z0-9!#$^&*|\-_+=~`?"]\.[A-Za-z0-9!#$^&*|\-_+=~`?"]+)*(\.{0,1}[A-Za-z0-9!#$^&*|\-_+=~`?"]@[A-Za-z0-9!#$^&*|\-_+=]{1,60})(\.[A-Za-z0-9!#$^&*|\-_+=~`?"]{2,60})*$"#).unwrap();
let string = "this.is.an.email@email.com
whatsinthebox@se7en
mpAdm1n@localhost
tyler.knappenberger@Gnostech.com
Damned.Proud.To.Be.Here@Gnostech.com
George.Washington@potus.gov
0123456789@numbers.num
~!#$^&*_-+|=?\"@special.chars
tknappenberger@student.lasalle.edu
jane.doe45@navy.gov
2.e@s
Not an Email@whitespace.org
this%doesntWork@percentsDont.work
duplicate..periods@localhost
.emalt@w";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}