const regex = /^[A-Za-z0-9!#$^&*|\-_+=~`?"]*([A-Za-z0-9!#$^&*|\-_+=~`?"]\.[A-Za-z0-9!#$^&*|\-_+=~`?"]+)*(\.{0,1}[A-Za-z0-9!#$^&*|\-_+=~`?"]@[A-Za-z0-9!#$^&*|\-_+=]{1,60})(\.[A-Za-z0-9!#$^&*|\-_+=~`?"]{2,60})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9!#$^&*|\\-_+=~`?"]*([A-Za-z0-9!#$^&*|\\-_+=~`?"]\\.[A-Za-z0-9!#$^&*|\\-_+=~`?"]+)*(\\.{0,1}[A-Za-z0-9!#$^&*|\\-_+=~`?"]@[A-Za-z0-9!#$^&*|\\-_+=]{1,60})(\\.[A-Za-z0-9!#$^&*|\\-_+=~`?"]{2,60})*$', 'gm')
const str = `this.is.an.email@email.com
whatsinthebox@se7en
mpAdm1n@localhost
tyler.knappenberger@Gnostech.com
Damned.Proud.To.Be.Here@Gnostech.com
George.Washington@potus.gov
0123456789@numbers.num
~!#\$^&*_-+|=?"@special.chars
tknappenberger@student.lasalle.edu
jane.doe45@navy.gov
2.e@s
Not an Email@whitespace.org
this%doesntWork@percentsDont.work
duplicate..periods@localhost
.emalt@w`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}