using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\\packages\\([^\\]*?)?\.(([\d]+(\.[\d]+){2,})(-[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?(\+[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?)\\.*";
string input = @"..\..\..\packages\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\lib\net45\Gherkin.dll";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}