import Foundation
let pattern = #".*\\packages\\([^\\]*?)?\.(([\d]+(\.[\d]+){2,})(-[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?(\+[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?)\\.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"..\..\..\packages\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\lib\net45\Gherkin.dll"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)