import re
regex = re.compile(r".*\\packages\\([^\\]*?)?\.(([\d]+(\.[\d]+){2,})(-[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?(\+[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?)\\.*")
test_str = "..\\..\\..\\packages\\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\\lib\\net45\\Gherkin.dll"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")