package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`.*\\packages\\([^\\]*?)?\.(([\d]+(\.[\d]+){2,})(-[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?(\+[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?)\\.*`)
    var str = `..\..\..\packages\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\lib\net45\Gherkin.dll`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}