import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\\\packages\\\\([^\\\\]*?)?\\.(([\\d]+(\\.[\\d]+){2,})(-[^\\\\\\-\\+\\.]+(\\.[^\\\\\\-\\+\\.]+)*?)?(\\+[^\\\\\\-\\+\\.]+(\\.[^\\\\\\-\\+\\.]+)*?)?)\\\\.*";
final String string = "..\\..\\..\\packages\\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\\lib\\net45\\Gherkin.dll";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}