// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\\packages\\([^\\]*?)?\.(([\d]+(\.[\d]+){2,})(-[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?(\+[^\\\-\+\.]+(\.[^\\\-\+\.]+)*?)?)\\.*").unwrap();
let string = "..\\..\\..\\packages\\SpecFlow.CustomPlugin.75-57-2.165d484.26546.75274.772570-test.12648.sdfg+test.sdg.1515\\lib\\net45\\Gherkin.dll";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}