#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^{{\w+}}(?:_{{\w+}})*$"
Local $sString = "{{word1}}_{{word2}}_{{word3}}" & @CRLF & _
"_{{word1}}_{{word2}}_{{word3}}." & @CRLF & _
"{{word1}}_word{{word2}}_{{word3}}" & @CRLF & _
"{{word1}}_{{word2}}_{{word3}}word4" & @CRLF & _
"{{word1}}_{{word2}}_{{word3}}_" & @CRLF & _
"_{{word1}}_{{word2}}_{{word3}}_" & @CRLF & _
"{{word1}}_{{word2))_{{word3}}" & @CRLF & _
"+{{word1}}-{{word2}}_{{word3}" & @CRLF & _
"word{{word}}_{{word2}}_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")