$re = '/^{{\w+}}(?:_{{\w+}})*$/m';
$str = '{{word1}}_{{word2}}_{{word3}}
_{{word1}}_{{word2}}_{{word3}}.
{{word1}}_word{{word2}}_{{word3}}
{{word1}}_{{word2}}_{{word3}}word4
{{word1}}_{{word2}}_{{word3}}_
_{{word1}}_{{word2}}_{{word3}}_
{{word1}}_{{word2))_{{word3}}
+{{word1}}-{{word2}}_{{word3}
word{{word}}_{{word2}}_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);