using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^{{\w+}}(?:_{{\w+}})*$";
string input = @"{{word1}}_{{word2}}_{{word3}}
_{{word1}}_{{word2}}_{{word3}}.
{{word1}}_word{{word2}}_{{word3}}
{{word1}}_{{word2}}_{{word3}}word4
{{word1}}_{{word2}}_{{word3}}_
_{{word1}}_{{word2}}_{{word3}}_
{{word1}}_{{word2))_{{word3}}
+{{word1}}-{{word2}}_{{word3}
word{{word}}_{{word2}}_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}