package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^{{\w+}}(?:_{{\w+}})*$`)
var str = `{{word1}}_{{word2}}_{{word3}}
_{{word1}}_{{word2}}_{{word3}}.
{{word1}}_word{{word2}}_{{word3}}
{{word1}}_{{word2}}_{{word3}}word4
{{word1}}_{{word2}}_{{word3}}_
_{{word1}}_{{word2}}_{{word3}}_
{{word1}}_{{word2))_{{word3}}
+{{word1}}-{{word2}}_{{word3}
word{{word}}_{{word2}}_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}