import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{\\{\\w+\\}\\}(?:_\\{\\{\\w+\\}\\})*$";
final String string = "{{word1}}_{{word2}}_{{word3}}\n"
+ "_{{word1}}_{{word2}}_{{word3}}.\n"
+ "{{word1}}_word{{word2}}_{{word3}}\n"
+ "{{word1}}_{{word2}}_{{word3}}word4\n"
+ "{{word1}}_{{word2}}_{{word3}}_\n"
+ "_{{word1}}_{{word2}}_{{word3}}_\n"
+ "{{word1}}_{{word2))_{{word3}}\n"
+ "+{{word1}}-{{word2}}_{{word3}\n"
+ "word{{word}}_{{word2}}_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}