const regex = /^{{\w+}}(?:_{{\w+}})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^{{\\w+}}(?:_{{\\w+}})*$', 'gm')
const str = `{{word1}}_{{word2}}_{{word3}}
_{{word1}}_{{word2}}_{{word3}}.
{{word1}}_word{{word2}}_{{word3}}
{{word1}}_{{word2}}_{{word3}}word4
{{word1}}_{{word2}}_{{word3}}_
_{{word1}}_{{word2}}_{{word3}}_
{{word1}}_{{word2))_{{word3}}
+{{word1}}-{{word2}}_{{word3}
word{{word}}_{{word2}}_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}