// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^{{\w+}}(?:_{{\w+}})*$").unwrap();
let string = "{{word1}}_{{word2}}_{{word3}}
_{{word1}}_{{word2}}_{{word3}}.
{{word1}}_word{{word2}}_{{word3}}
{{word1}}_{{word2}}_{{word3}}word4
{{word1}}_{{word2}}_{{word3}}_
_{{word1}}_{{word2}}_{{word3}}_
{{word1}}_{{word2))_{{word3}}
+{{word1}}-{{word2}}_{{word3}
word{{word}}_{{word2}}_";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}