# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/",?//g;t' <<< "\"2014\", \"2\", \"AMC-South\", \"inpatient\", \"complication\", \"1\", \"2\", \"2\", \"13,125.83\", \"6,562.95\"
"