const regex = /",?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('",?', 'g')
const str = `"2014", "2", "AMC-South", "inpatient", "complication", "1", "2", "2", "13,125.83", "6,562.95"
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);