import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\",?";
final String string = "\"2014\", \"2\", \"AMC-South\", \"inpatient\", \"complication\", \"1\", \"2\", \"2\", \"13,125.83\", \"6,562.95\"\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}