#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)S-2(.*)$"
Local $sString = "Some text SELLO S-2 BREAK &Logic,0" & @CRLF & _
"Some other text SELLO S-2_BREAKTWO &Logic,0" & @CRLF & _
"Wear EXT &SELO-344 S-2,0,30"
Local $sSubst = "$0\n$1S-4$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)