import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)S-2(.*)$";
final String string = "Some text SELLO S-2 BREAK &Logic,0\n"
+ "Some other text SELLO S-2_BREAKTWO &Logic,0\n"
+ "Wear EXT &SELO-344 S-2,0,30";
final String subst = "$0\\n$1S-4$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}