const regex = /^(.*)S-2(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)S-2(.*)$', 'gm')
const str = `Some text SELLO S-2 BREAK &Logic,0
Some other text SELLO S-2_BREAKTWO &Logic,0
Wear EXT &SELO-344 S-2,0,30`;
const subst = `$0\n$1S-4$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);