re = /^(.*)S-2(.*)$/m
str = 'Some text SELLO S-2 BREAK &Logic,0
Some other text SELLO S-2_BREAKTWO &Logic,0
Wear EXT &SELO-344 S-2,0,30'
subst = '$0\\n$1S-4$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result