import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^[^=:\\r\\n]+[=:]|\\G(?!^))(?:b\\d{1,2})?\\K.*?(?=b\\d{1,2}|$)";
final String string = "Accept-Language: en-EN\n"
+ "n1.legend=0,1,meta,text,Legend,b1,30 chars max\n"
+ "n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test\n"
+ "r1.label=Contain\n\n"
+ " en-EN\n"
+ "0,1,meta,text,Legend,b1,30 chars max\n"
+ "0,1,meta,text,Legend,b1,30 chars maxb12test\n"
+ "Contain";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}