const regex = /(?:^[^=:\r\n]+[=:]|\G(?!^))(?:b\d{1,2})?\K.*?(?=b\d{1,2}|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^[^=:\\r\\n]+[=:]|\\G(?!^))(?:b\\d{1,2})?\\K.*?(?=b\\d{1,2}|$)', 'gm')
const str = `Accept-Language: en-EN
n1.legend=0,1,meta,text,Legend,b1,30 chars max
n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test
r1.label=Contain
en-EN
0,1,meta,text,Legend,b1,30 chars max
0,1,meta,text,Legend,b1,30 chars maxb12test
Contain`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}