$re = '/(?:^[^=:\r\n]+[=:]|\G(?!^))(?:b\d{1,2})?\K.*?(?=b\d{1,2}|$)/m';
$str = 'Accept-Language: en-EN
n1.legend=0,1,meta,text,Legend,b1,30 chars max
n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test
r1.label=Contain
en-EN
0,1,meta,text,Legend,b1,30 chars max
0,1,meta,text,Legend,b1,30 chars maxb12test
Contain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);