import Foundation
let pattern = #"(?:^[^=:\r\n]+[=:]|\G(?!^))(?:b\d{1,2})?\K.*?(?=b\d{1,2}|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Accept-Language: en-EN
n1.legend=0,1,meta,text,Legend,b1,30 chars max
n1.legend=0,1,meta,text,Legend,b1,30 chars maxb12test
r1.label=Contain
en-EN
0,1,meta,text,Legend,b1,30 chars max
0,1,meta,text,Legend,b1,30 chars maxb12test
Contain
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)